
First Look at ArcMap 

Shapefiles 
We have already used Shapefiles in last week’s exploration of ESRI datasets we 
had on our local machines.  Let’s take a closer look at this popular and commonly 
used GIS format. 
The first thing that you’ll notice is that shapefiles are not a single file but as many as 
eight and at least three files (*.shp, *.shx, and *.dbf) all of which have the same high-
level qualifier but different file-type suffixes.  For instance, let’s take a look at files in 
the directory ?†:\Courses\GIS in Geology\Week #2\datasets\counties: 

COUNTIES.DBF 
COUNTIES.SBN 
COUNTIES.SBX 
COUNTIES.SHP 
COUNTIES.SHX 

ESRI provides a quite involved discussion of the format and contents of shapefiles in 
their whitepaper.  Below is a brief description of each file’s content: 

*.aih Required if part 2 of the Attribute Index of the active fields in a Table 
or a Theme's Attribute Table is comprised of this file. It's automatically 
created whenever you "Link tables" and also when you "Create Index" 
for a field.  

*.ain Required if part 1 of the Attribute Index of the active fields in a Table 
or a Theme's Attribute Table is comprised of this file. 

*.avl Optional legend for the shapefile can be stored in this file. 
*.dbf dBase file attribute table for the shapefile "theme" 
*.prj Projection information (not used by ArcView 3.x) 
*.sbn Required if part 1 of the Spatial Index of the features is comprised of 

this file. 
*.sbx Required if part 2 of the Spatial Index of the features is comprised of 

this file 
*.shp Feature Geometry for each shape 
*.shx Index of Feature Geometry 

One of the most common mistakes by first-time shapefile users is not appreciating 
that, when copying a shapefile to a new location, all of the ancillary files must be 
copies as well.  When copying a shapefile make sure get all files with the same high-
level qualifier as the shapefile. 

                                                 
†  Because the drive letter assigned to geocopter will differ from machine to machine, I have replaced 

it with “?”. 

http://www.esri.com/library/whitepapers/pdfs/shapefile.pdf
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Global Mapper as Rosetta Stone 
One of the most useful and powerful features of Global Mapper is that it will read 
virtually any GIS data no matter its format.  Although ArcMap can do the same thing 
(and more) the process is quite involved and time consuming whereas in Global 
Mapper it’s simply a matter of pointing and clicking.  A second wonderful capability 
of Global Mapper is it’s ability to export either raster or vector GIS data into any one 
of the more commonly used formats (including ESRI’s).  Let’s give it a try. 
 

Start Global Mapper, and click , navigate to ?:\Courses\GIS in Geology\Week 
#2\datasets\counties and open the counties shapefile.  You should see the following 
pop up warning that there is no projection data supplied for the counties shapefile. 

 
Press “OK” and this dialog box will appear: 
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Note that Global Mapper is clever enough to guess that the dataset is in geographic 
coordinates (latitude and longitude).  Press “OK” again and you should see the 
image below.  

 
As was mentioned last week, the actual displaying of GIS data in Global Mapper is 
rather limited… for that we use ArcMap.   
This particular dataset is already a shapefile so it could be read directly by ArcMap 
but let’s export to a shapefile anyhow and add projection data.  Select File>Export 
Vector Data>Export Shapefile and the dialog box shown below will appear (if you 
haven’t disabled it already, a small information box may appear before the dialog 
box): 
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Shapefiles may consist of one of the three types of geometric objects: polygons (aka 
areas), lines (aka polylines) and points.  A polygon consists of at least three line 
segments forming a completely enclosed area.  Polylines consists of one or more 
line segments.  A point is a single coordinate pair.  It’s a good idea to try to export all 
of these object types even if the map only consists of one object type (e.g., the 
counties dataset only consists of polygons).  Click in the “Export Areas” box and 
specify the location and name of the polygon shapefile: 

 



First Look at ArcMap page 5 

Repeat the procedure for polylines and points (because there are none of these 
objects in counties, these files won’t be generated).  Make sure to click the 
“Generate projection…” box.  Click the “OK” button and the shapefile will be 
generated.  Note that a *.prj file has been added to the shapefile files group. 

ArcMap 
Fire up ArcMap and you should see something that looks like this: 

 
Your screen may look a bit different depending on what toolbars have been specified 
for display.  Press View>Toolbars and make sure that the first five click boxes are 

checked.  Let’s add our counties shapefile or theme.  Click the yellow  button 
and use the resulting dialog box to navigate to the counties file that you generated 

earlier on your local machine.  You may have to click the  button to navigate to 
the right location. Once the counties theme has been added, your screen should 
look something like this: 



First Look at ArcMap page 6 

 

Reprojecting a View 
Our counties map is displayed in geographic coordinates so it looks distorted.  Let’s 
reproject it into a more familiar form.  Right click on the map and select  Properties.  
The following dialog box should appear 

:  
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If “Coordinate System” is not the selected tab, select it.  Click on the “Predefined” 
folder then the “Projected Coordinate Systems” folder, then the “Continental” folder, 
then the “North America” folder.  Select  “USA Contiguous Albers Equal Area Conic” 

and click the “OK” button.  Click the magnify ( ) button and click and drag over 
the contiguous states.  You should have something that looks like this: 

 

Symbology 
All right, let’s us some of ArcMap’s great display capabilities.  Double click on the 
word “counties” in the left hand panel or right click on it and select “Properties”.  A 
dialog box will appear.  Click the “Symbology” tab.  Click “Unique values” under 
“Catagories”.  Pull down to STATE_NAME on the “Value Field” menu and pull down 
to a pleasing color scheme on the “Color Scheme” menu.  Click the “Add All Values” 
button and you should get something that looks like this: 
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Click “OK” and you should see this: 

 



First Look at ArcMap page 9 

Note that you can change any color by clicking on the corresponding color panel in 
the symbology dialog box.  Double click on the Bama panel and pull down the fill 
color panel to some distinct color. 

 
Click “OK” and verify the color for Alabama has changed on the map. 

Attributes Table 
Every feature in a theme has attributes.  We already examined feature attributes in 

Global Mapper by clicking on a feature with the pick tool ( ).  The attribute table 
is stored in the *.dbf file and can be read directly with Excel.  Open Excel select 
File>Open and when the dialog box appears, navigate to where you stored the 
counties shapefile.  Pull down to “dbase files” from the “Files of type: “ menu and 
counties.dbf should appear.  Open the file.  Whatever you do CHANGE 
ABSOLUTELY NOTHING… NOTHING… NOT EVEN COLUMN WIDTH.  
Take a look at the data for all the counties in the US.   
We can bring up a similar looking spreadsheet called the attribute table by again 
right clicking on the word “counties” in the left-hand panel and selecting “Open 
Attribute_Table”.   
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Although it’s not something we’d do as geologists, let’s add some data.  Select “Add 
Field…” from the “Options” pull down.  Fill in the dialog box as shown below: 

 
This will add a field to the table at the left-hand side. 
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Left click on the column heading of the new column and select “Calculate Value”.  
You’ll receive a warning dialog.  Press “OK” and the following dialog should appear: 

 
Click “BLACK” in the right column, type “/” then click POP1999, then type “*100”.  
The dialog box should now look like this: 
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Click “OK” and voila: 

 

Reprojecting a View 
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Okay, let’s display the data we just generated (again, this feature would rarely be 
used by geologists but…).  Close the attribute table and once again display the 
counties theme properties by right clicking “counties” in the left-hand panel.  Again, 
click on the “Symbology” tab.  This select “Quantities” and “Graduated colors”.  Pull 
down to “RACE_RATIO” under “Value:”: 

 
Click “OK” and you should get something that looks like this. 
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Fun with SAMP 
The statewide Unconsolidated Aquifer Map (SAMP) is a wonderful dataset that can 
be used to demonstrate the power (and frustrations) of GIS.  It may be downloaded 
as either a shapefile or ArcInfo coverage from this site.  As we have seen, shapefiles 
may be read directly by ArcMap.  Coverage (.e00 files) are not directly readable but 
can be converted fairly easily with ESRI-provided software.  They can, however, be 
very easily read with Global Mapper.   
I have downloaded and unzipped the SAMP coverage to the course site on 
geocopter (?:\Courses\GIS in Geology\Week #2\datasets\SAMP).  The dataset is 
very well documented.  Open and read the “Read Me” file and “Unconsol Legends” 
documents to understand the attribute table of the dataset. 
Creat a new folder on your local machine called “SAMP” and copy ohglaqua.e00 
from the “Map” folder on geocopter to your machine.  Open Global Mapper and have 
it read ohglaqua.e00 (make sure you open it on your local machine). 

http://www.ohiodnr.com/water/samp/uncon_coverages.htm
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Global Mapper is smart enough to read the projection information from the file… 
unfortunately it reads it incorrectly (it get the state plane and units right but it thinks 
the state is Alaska. 
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Using the same procedure we used previously, export the map into shapefiles 
(polygons, polylines and points… even though there are no points) let’s not generate 
a projection file because it’s wrong. 
Open ArcMap and add the polygon theme you just generated.  Right click the theme 
name in the left-hand panel and click the “Symbology” tab.  Select “Quantities”, 
“Graduated Colors” and set the “Value” field to “YIELDCODE”.  As you saw by 
reading the  “Unconsol Legends” document (you did do that, right?), there are 6 
different codes, 1-5 and 99.  Set   Pull down the “Classes” menu to “6” and the 
“Classify” button.  Set the break values to 1, 2, 3, 4, 5, and 99 then click “OK”.  
Symbology should look like this: 

 
Double click the red block corresponding to 6-99 and pull down to “No Color” on the 
fill menu.  Click “OK” and then “OK”  You map should look like this: 
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First Stab at Laying out a View 

At the bottom right of the right-hand panel, you’ll see teo “buttons”, .  The left, 
highlighted button is the “data view” while the right button is the “layout view”.  Click 
the  button.  This will take you to the layout window in which you should see your 
map (sizeable) on a background showing page size.  We’ll do much more in this 
view later but for the time being, we’ll just generate a legend for our map.  From the 
menu at the top of the window select Insert>Legend.  Keep clicking “Next” and finally 
“Finish”.  This should place a moveable legend panel on your map.  Move it over to 
an empty spot on the map. 
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At this point you may either export the map (File>Export Map and select *.emf as the 
format) for easy placement in a document or send it directly to a printer. 
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Legend
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Saving an ArcMap Project 
ArcMap projects are simply saved the first time by invoking File>Save As and 
thereafter by File>Save.  Projects as saved as file type *.mxd.  It should be clearly 
understood, however, that the actual data is not saved with the project; just the 
location of the datasets and how they are to be placed and displayed (otherwise the 
project file would be enormous).  This means if you move or delete the input 
datasets you will need to either regenerate or find them using the procedure that will 
be demonstrated in class.  Remember, if you plan to save a project to a CD or to a 
different machine, make sure to save all the datasets that it uses with it.  Despite this 
warning, you are certain to make this error at some point so don’t erase anything 
until you are able to open your project successfully from its new location. 
It is generally a good idea to store all of your themes in one subdirectory directly 
below the directory in which you store the ArcMap (*.mxd) project. 


